archive-com.com » COM » M » MAPDOTNET.COM

Total: 438

Choose link from "Titles, links and description words view":

Or switch to "Titles and links view".
  • Layer legend: no longer responding to click events - MapDotNet
    clicking all over on any one of our eight layers but to no avail nothing happens I ve tried putting a breakpoint in the click event that is set up in buildLegend in isc touchgeo layer js but it never gets hit not that I m sure that it would since it s defined in the kendoMobileListView function nor do any alert messages that I added ever show up The site is accessible here can you tell what might be causing this We also upgraded our version of jQuery to 1 9 1 when we upgraded the isc rim js version but other than that there have been no significant changes Thanks Chris Tweet Responses 3 Likes Highest Vote Latest Oldest Accepted Answer Registered By Chris Early Wednesday March 13 2013 07 00 PM permalink 0 Well I just rolled back the isc rim js version to 8 3 2000 0 and the jQuery version to 1 7 2 and now it s working again We really can t afford to wait for a fix so I ll keep our version at 8 3 for now If you re able to reproduce this or determine the cause of it we would still want to have it fixed so that we can eventually upgrade to 9 0 Thanks The reply is currently minimized Show Accepted Answer By Brian Hearn Tuesday March 19 2013 02 38 PM permalink 0 Chris are all of your tests of touchgeo with these issues on Chrome surface pro The reply is currently minimized Show Accepted Answer Registered By Chris Early Thursday March 21 2013 02 48 PM permalink 0 Yes they are A bit of a unique arrangement but it s the only one that works for our client s needs standalone mode and online mode

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/layer-legend-no-longer-responding-to-click-events (2016-04-26)
    Open archived version from archive


  • Windows Surface Pro: pinch to zoom bug in version 9.0 of isc.rim.js - MapDotNet
    Pro tablet again Here is what I have observed so far 1 The issue identified in this post still happens but only after you do something to change the map If I tap the switch to turn Bing Aerials on then the pinch to zoom is broken again but if I don t do anything except pan and zoom around it works fine Can you reproduce this on your end 2 The digitizer stylus support has gotten better but it still is a bit quirky at least on our tablet we ve switched out the overheating Surface Pro for the Panasonic FZ G1 with Windows 8 Specifically the tabstrip only works with the stylus after you first tap on one of the tab buttons with your finger Have you been able to use the stylus without issue on the Surface pro Thanks Chris Brian Hearn more than a month ago 1 The Chrome browser on Surface continues to have issues and we have not been able to resolve them Visit mapsjs com for a new version that does eliminate the canvas transform shake issue on Chrome 2 This would be an issue with Kendo Mobile Sorry to only have bad news here The reply is currently minimized Show Responses 2 Likes Highest Vote Latest Oldest Accepted Answer By Brian Hearn Tuesday March 19 2013 02 31 PM permalink 0 We are now testing RIM against the surface pro and have verified this issue We will look into it Thanks The reply is currently minimized Show Accepted Answer Registered By Chris Early Tuesday May 07 2013 06 58 PM permalink 0 Thanks Brian we also have run into a problem with Chrome on Windows 8 tablets where the keyboard shows and hides quickly when you tap on an input type text

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/windows-surface-pro-pinch-to-zoom-bug-in-version-9-0-of-isc-rim-js (2016-04-26)
    Open archived version from archive

  • Could not log in once logged out in isc.rim.js version 9.0.0002.2 - MapDotNet
    Chris Early Wednesday March 13 2013 07 14 PM 0 Sorry for the peppering of posts but I m just posting everything I m observing as I go along I m sure version 9 0 added a lot of new things but other things aren t working as well at least for us We had upgraded the version to 9 0 0002 2 and then had just hit refresh on the browser and kept on using the touchGeo website we ve been developing However at some point we got logged out and had to log back in we ve just been using the backdoor username password The problem though is that we never saw the authentication dialog the screen had the grayed out look to it but no dialog was displayed I tried looking at the page elements and found the dialog div and even tried manipulating it to get it to show up but to no avail The only way around it was to hardcode the backdoor username password in to isc touchgeo authenticate js This is another issue that will prevent us from upgrading to 9 0 once we went back to 8 3 it s working fine again If you need another more details to repro investigate let me know Thanks Chris Tweet Responses 1 Likes Highest Vote Latest Oldest Accepted Answer By Brian Hearn Tuesday March 19 2013 02 33 PM permalink 0 We are scheduled to release an upgrade to touchgeo on RIM9 I will ensure QA looks for this before release Thanks The reply is currently minimized Show Your Reply Please login to post a reply You will need to be logged in to be able to post a reply Login using the form on the right or register an account if you are

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/could-not-log-in-once-logged-out-in-isc-rim-js-version-9-0-0002-2 (2016-04-26)
    Open archived version from archive

  • Error popups after leaving touchGeo website open for extended period of time - MapDotNet
    After leaving touchGeo open in the browser for a long period of time overnight say upon coming back and switching to the touchGeo tab there is this error message displayed ajax call to rest http domain URL TouchgeoWeb1 0 REST 8 0 Map TouchGeo Tag Format json resulted in error Have you guys seen this It isn t a blocking issue but it does get rather annoying to see that every time you leave touchGeo alone for a while If we don t see this error though we ll then get this next one instead on the desktop as well when we try to modify anything on the map add edit delete setFeatureAsync Your access is invalid or your session has timed out please log in to continue Is there a way to handle a session timeout so that the user doesn t see it after they ve already made modifications and try to save them Do we need to forcibly log them out after a period of time It d be nicer if they didn t have to do that and could just keep using touchGeo even after leaving the browser open for an extended period of time Thanks Chris Tweet Accepted Answer By Brian Hearn Tuesday March 26 2013 08 57 PM permalink 0 This is due to the security token expiring after one hour of logging in The latest internal version has support for auto renewing this so you do not have to in your code The reply is currently minimized Show Responses 1 Likes Highest Vote Latest Oldest Accepted Answer Registered By Chris Early Monday April 01 2013 10 46 PM permalink 0 Ah good to know Will be looking forward to the next release The reply is currently minimized Show Your Reply Please login to

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/error-popups-after-leaving-touchgeo-website-open-for-extended-period-of-time (2016-04-26)
    Open archived version from archive

  • After waiting on the editor panel view for about 4 minutes, it resets to "Click add to create new [Default layer name]" - MapDotNet
    by design is there a way to turn it off or if it is not do you know where I should start looking to track down the cause of this Thanks Chris Tweet Responses 3 Likes Highest Vote Latest Oldest Accepted Answer Registered By Chris Early Monday May 06 2013 06 33 PM permalink 0 Aha so I just found the source of the issue in isc touchgeo authenticate js entry point periodically every 5 mins re auths to get updated session token this start function this begin setInterval this begin 300000 The timer calls this begin which in turn eventually calls setupTouchgeo in index html This then calls isc touchgeo editorMgr notifyResetEditor which resets the editor panel to the default view Do we need to be re authenticating every 5 minutes or can we safely extend this to 15 minutes or 30 minutes The reply is currently minimized Show Accepted Answer Registered By Chris Early Tuesday May 07 2013 10 35 PM permalink 0 So this is actually proving to be a big problem for us our application has users adding a point then walking down the street for quite a while then adding another point and filling in field attributes This process is often longer than 5 minutes so we re seeing TouchGeo reset the active feature that is being added and wiping all the data Can we turn off the periodic re auth Also I m not sure what I did but in upgrading our main server the authenticate js file not longer has the above start function with the setInterval function but Touchgeo is re authenticating nonetheless A bit confused about that too Thanks Chris The reply is currently minimized Show Accepted Answer Registered By Chris Early Wednesday May 15 2013 10 48 PM permalink 0

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/after-waiting-on-the-editor-panel-view-for-about-4-minutes,-it-resets-to-click-add-to-create-new-default-layer-name (2016-04-26)
    Open archived version from archive

  • New Type = lookup format is an array, how to use? - MapDotNet
    an instance of an object last operation completed parsed mappings into feature How can we save an empty value into a lookup field Thanks for the help Chris Tweet Accepted Answer Registered By Chris Early Thursday May 09 2013 11 26 PM permalink 0 Alright finally tracked the real issue down we had a few null values for empty photo fields that we were trying to save along with other empty lookup field values It s the null values that are causing the error Once I changed these to just be empty strings the save worked Sorry for the hassle should ve checked that sooner The reply is currently minimized Show Responses 3 Likes Highest Vote Latest Oldest Accepted Answer By Brian Hearn Tuesday May 07 2013 05 59 PM permalink 0 let us look into this one The reply is currently minimized Show Accepted Answer By Brian Hearn Wednesday May 08 2013 04 58 PM permalink 0 As for 1 we did identify an issue for hard coded lookups in your map metadata and we have an available fix Please note For hard coded lookups in your metadata the key and value are the same thing This is expected to be used where you have a unique set of options to choose from similar to an option set in CRM It is not meant to support a FK lookup in SQL where you are updating a key for a given display value similar to an entity reference in CRM The reply is currently minimized Show Accepted Answer Registered By Chris Early Wednesday May 08 2013 11 07 PM permalink 0 Ok that s not a problem for us we re not looking to try to use separate key and values just thought maybe it was the new way of

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/new-type-lookup-format-is-an-array,-how-to-use (2016-04-26)
    Open archived version from archive

  • Latest version of TouchGeo (1.3.1) not showing picture preview for photo field - MapDotNet
    posted in touchgeo HTML5 Code Base Registered By Chris Early Monday May 06 2013 05 52 PM 0 Just another quirk we ve noticed since upgrading from version 1 08 to version 1 3 1 on Chrome on Windows 8 Pro on a tablet and Chrome on a Windows 7 desktop I should add photo fields no longer show a preview of the picture that was selected Is this by design or a bug It was nice to be able to see the picture that you just took when using a mobile device Thanks Chris Tweet Accepted Answer Registered By Chris Early Tuesday May 07 2013 06 47 PM permalink 0 OK this one was my fault bad path in the Web config PhotoVirtualRoot key Fixed that and the pictures are showing again just fine The reply is currently minimized Show Responses 0 Likes Highest Vote Latest Oldest There are no replies here yet Your Reply Please login to post a reply You will need to be logged in to be able to post a reply Login using the form on the right or register an account if you are new here Register Here Register Username Forgot Password Password Remember

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/latest-version-of-touchgeo-1-3-1-not-showing-picture-preview-for-photo-field (2016-04-26)
    Open archived version from archive

  • Editing a line feature: Cannot drag a node from a short line without creating another node - MapDotNet
    between the original two points This doesn t happen on longer line segments we ve been able to drag the second point around without a third point being added Any ideas as to why this is happening Can you reproduce this on your end Thanks Chris Tweet Responses 7 Likes Highest Vote Latest Oldest Accepted Answer By Russell de Grove Thursday June 20 2013 01 53 PM permalink 0 I ve passed this on to the appropriate developer Sounds like the ghost node is getting the drag event instead of the live node when the two overlap The reply is currently minimized Show Accepted Answer By Brian Hearn Thursday June 20 2013 02 51 PM permalink 0 We have identified the issue and will resolve it for the next drop The reply is currently minimized Show Accepted Answer Registered By Chris Early Friday June 21 2013 10 04 PM permalink 0 Thanks guys The reply is currently minimized Show Accepted Answer By Brian Hearn Tuesday June 25 2013 05 30 PM permalink 0 The current version at mapsjs com has this resolved The reply is currently minimized Show Accepted Answer Registered By Chris Early Wednesday July 24 2013 11 23 PM permalink 0 Whoops haven t checked back on this in some time thanks Brian The reply is currently minimized Show Accepted Answer Registered By Chris Early Wednesday July 24 2013 11 35 PM permalink 0 Hmmm well I may have marked this as Answered too soon since after using the latest isc rim js file our touchgeo website no longer loads and I had to revert right away The line it s bailing on is line 24 of isc touchgeo map js var mdnDescriptor new isc rim tile descriptorMDNRestMap mapId And the error it gives is undefined is not

    Original URL path: http://www.mapdotnet.com/index.php/developers-center/discussions/editing-a-line-feature-cannot-drag-a-node-from-a-short-line-without-creating-another-node (2016-04-26)
    Open archived version from archive



  •